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Chapter 4. The SEARCH Mode

The SEARCH mode cnables you to create, view, manipulate, and
analyze word and phrase searches. Advanced users can create sophis-
ticated compound searches by merging searches using the AND, OR,
XOR, and NOT logical operators.

The fult range of SEARCH features is available for VIEW windows and
is covered in this Chapter. To focus on SEARCH features pertaining

specitically to COMMENTARY, TOPICS, and LLEXICON windows, see
Chapter 5.

Performing a Search

To SEARCIH from the VIEW mode, click the Word/Phrase button L@
or seleet Word/Phrase... from the Search menu and enter a word or [
phrase. For our example, let’s
search KIS for the phrase “the
day ol the Lord™;

Word Order 1s “L.iteral” and
Case Sensitivity is off.

The result 1s this SEARCH window:
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fsal 13:6 Howl ye; for the day of the LORD [ is] at hand; it shall con
[za1 13:9 Behold, the day of the LORD cometh, cruel both with wra
Jere<46:10  For this [is] the day of the Lord GOD of hosts, a day of v
Ezek 13:5  wvenot gone up into the gaps, neither made up the hedge tor
Ezek 30:3  For the day [is] near, even the day of the LORD [is] near, 38
Joel 1:15 Alas tor the day! for the day of the 1.ORD [is] at hand, anc
iJoel 2:1 Blow ve the trumpet in Zion, and sound an alarm in my holy
Joel 2:11 And the LORD shall utter his voice before his army: for hisg
Joel 3:14 udes, multitudes in the valley of decision: for the day of (hé@
Amos 5:18  nto vou that desire the day of the LORD! to what end [is] i
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Duc to the “Literal” setting, Companion screened 380 possible verses for
the exact phrase “the day of the Lord.”

Hit Highlighting

The previous window is a good example of hit highlighting. All
SEARCH phrase words are highlighted-cven words outside “litera]”
order (Sec Jere 46:10 above). This shows you uses of the words you
might otherwise miss. If you use wildeards (see below), only the root
word is highlighted. For instance, if you search on “*fop*” the high-
lighting would look like: beloved, lovely, loving, love, el

Companion gives you control over the fragments of the verses shown.
The Screen Format dialog box on the Options menu gives vou the choice
ol using no fragments (very fast), the beginning of the verse, or using the
context of one of the SEARCH words. 1f Word Context is chosen, the
fragment is centered on the first SEARCH word lound. {It may not be
part of a phrase (sce Izek 13:5 above). Remember, you can just move
the selection bar to a verse and press <Enter> to PEEK at the entire
verse i context (the search words will continue to be highlighted).

Entering Word/Phrases
Paste Sel

You can select a word or phrase out of the Bible text (o use in the
Word/Phrase dialog box. Simply highlight the text in a VIEW window
with the mouse before you enter the Word/Phrase dialog box. Then click
Paste Sel to insert that text in the Word/Phrase dialog box.

Using the Word List

As you type a word in the Word/Phrase dialog box, the Word List tries to
match your word as closely as possible. To substitute one of the words in
the Word List for your current word, just double-click it.

Using Strong’s Numbers

If you have the STR database, you can search for Strong’s number(s).
(Prefix Old Testament numbers with a zero “0”. Example: OT #1 should
be “017.) Strong’s numbers can be used alone in the Word/Phrase dinlog
box or added to any phrase—even for non-Strong’s ditabases (such as
NIV). Strong’s numbers are ignored for Word Order purposes. In elTect,
they operate as a logical AND against any phrase words. The search
results use the Bible text you started the SEARCH from.
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Wildcards

You can use the asterisk character “*” 1o act as a wildcard. The wildcard
can be at the beginning and/or the end of a word. These are valid
examples: “lov*”, “Feth”, “*come™”. You may not embed the wildcard
in a word, The following examples are invalid: “*med”, “spir*t”. Wild-
cards are especially useful in searching Greek text for root words.

Punctuation

Punctuation is ignored for searching purposes.

Using Spanish/Greek/Hebrew Characters

II'you want ta type accented characters for a Companion Spanish data-
base, type an apostrophe before the accented character. Ta type an
accented e type ‘e, The characters appear in the special window below. If
you lype Gireek or Hebrew, the special window displays the text in your
chosen screen fonlt.

Option Buttons

Case Sensitivity

You can choose to enforce Case Sensitivity. Tf you do, Companion finds
lerms whose case (capitalization) matches.

Word Order

Il you have a phrase, you can choose to enforce Word Order.

« Il you choose “None,” Companion [inds any verse(s) in the search
range that has'the words—in any order. This is the fastest method.

» Toenforce Word Order, use “General” or “Literal” order. “General”
requires the words be found in order, but other words are allowed in
between. “Literal” order enforces word order and does not allow
words in between. Since Companion must screen each potential
verse, searches that enforce Word Order take longer.

If you are already enforcing Case or Word Order, adding the other won’t
add much additional time to your search.
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Possible Phrase Errors
There are potential errors in a phrase search and the following are failure
messages. After each, we provide an explanation and suggestions.

Above word(s) were not recognized.
You typed in a word or a wildeard that is notin the Bible. Start o new
study. Get in WORD mode for spelling help if yvou need it.

Above word(s) were not in search range(s).
Your word(s) are valid, but are not in the scarch range. “Apostle
Paul” is not in Genesis. Review your range on the Search menu.

Words not together in verse in search range(s).

The words were recognized, and they are in the search range. Bul,
they are not found together in even one verse. Check your search
range or modify the search phrase.

Words don’t match your order in search range(s).

You would have had some “hits,” but you specilied “General” or
“Literal™ Word Order. That eliminated the potential hits. Consider
relaxing your Word Order, changing your scarch range, or altering
your phrase.

Words don’t maich case in search range(s).

You would have had “hits,” but you enforced Case Sensitivity. That
eliminated the potential hits. Try changing the case you used in your
phrase, running the search without Case Sensitivity (1o sce whal case
does exist), or altering your scarch range,

No order and/or case match in search range(s).

You would have had some hits, but you enforced both Word Order
and Case Sensitivity. One or both eliminated the hits. (Companion
can’t telt which—or if it was both. That would slow searches greatly.)
Elimimate Word Order or Case Sensitivity and search.again You can
also examine the search range and the phrase.

User aborted search by pressing <Kse>.

Since Companion allows you to abort long searches (when you en-
force Case Sensitivity or Word Order) by pressing <Esc>, this isn’t a
failure message—you simply stopped the search manually.
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Using SEARCH Resulis
Scrolling SEARCH Verse References

Once you are in the Search window, you can move to other verses using
the following keys:

Movement Keys
Gio to beginning of references <Home>
Go to end of references <End>

Move up one verse
Move down one verse
Go to top of window, scroll if required

Go to end of window, scroll if required

Toggling Verse References

<Up> or <l.eft>
<Down> or <Right>
<PgUp>

<PgDn>

Verse references are toggled by pressing the <Space> bar (or select
Toggle on the Edit menu). If an “*” is beside the verse, it is toggled ON.
This example shows “the day of the lord” verses in Isaiah 1oggled:

= b B

File Edit View Search Words Qplions Window H

HHERE e =l =l

sui 13:6
a1 13:0
Jere 46:10
Hrek 13:5
Ezek 30:3
Joel 1:15

I Joel 2:1

Ml Joel 2:11
Joel 3:14

Howl ye; for the day of the LORD [is] at hand; it shall cor
Behold, the day of the LORD cometh, cruel both with wra "
For this [is] the day of the Lord GOD of hosts, a day of v
ve 1ot gone up into the gaps, neither made up the hedge for
For the day [is] near, even the day of the LORD [is] near,
Alas for the day! for the day of the LORD [is] at hand, an
Blow ye the trumpet in Zion, and sound an alarm in my holyg
And the T,ORD shall utter his voice before his army: for his
udes, multitudes in the valley of decision: for the day of the

Amos 5:18  nto you that desire the day of the LORD! to what end [is] il

+

P

[ you toggle a verse twice, the disappears and the verse is toggled
OFF. Toggled verses are used in printing and in reducing verses.

Reducing SEARCH Verse References

To reduce a list to the toggled verses (removing others) pick Delete Non-
Toggled on the Edit menu. This option makes a verse list manageable,
allowing you to select pertinent verses. For example, if you search for
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“lie,” you are probably looking for either the “Talschood” or “reclining”
meaning—but not both. Be sure your toggles are correct. You must restar
the SEARCII 1o get them back. For Isaiah, the result 1s:

= ¥]a

File Edit View Search Words Options Windew Hel

R E

| 3 8 R

i ) 2 day ¢ e LORD ¢ g ifs On eve :
Isai 13:6 Howl ye; for the day of the LORD [is] at hand; it shall con
Isar 13:9 Belold, the day of the LORD cometh. cruel both with wra

Adding Verse References
To add a verse or verse range to a verse reference list, select [nsert...
from the Edit menu. You are asked for the verse range (o add.

Deleting Verse References

To delete a selected verse, press <Del>.

PEEKing at SEARCH Verse References in Context

You can PEEK at a verse in context by pressing <Enter> on il. In our
previous example, a PEEK at Isaiah 2:12 would look like:

= vl

File Edit View Search Words Options  Window Help

o m |l o) [ ] BN (2] (] [ ] L () 2 e
[kas king vames o B3 [ErnlfRl (2] ) HEEAEY ) ) cucu

a

“For the day of the LORD of hosts [shall be] upon every [one that is] &)
proud and lofty, and upon every [one that is] lifted up; and he shall be
brought low: ™ And upon all the cedars of Lebanon, [that are] high and
lifted up, and upon all the oaks of Bashan, * And upon all the high
monntains, and upon all the hills [that are] lifted up, * And upon every
high tower, and upon every fenced wall, ¥ And upon all the ships ol
Tarshish, and upon all pleasant pictures. {pleasant. .- Heb. pictures of
desire} " And the loftiness of man shall be bowed down. and the
haughtiness of men shiall be made low: and the LLORD alone shall be
exalled in that day. * And the idols he shall utterly abolish, {he...: or,
shall utterly pass away} ** And they shall go into the holes of the rocks,
and into the caves of the earth, for fear of the LORD, and for the glory
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Synchronizing VIEWs to SEARCH

You can synchronize VIEW or PEEK windows (o a SEARCIH
window. This means that any visible VIEW or PEEK syn-
chronizes to the current verse in a SEARCH mode window. You
can view a SEARCH verse in context as in PEEK, while the SEARCI is
still displayed on the screen. Also, you can view a SEARCH verse in
different Bible versions, or even use Interlinear Form. The only
ditference 1s that the SEARCH words are not highlighted.

file Ld

il rer ; .
EE R E e R

| {5 el

B Sachaveses _ HA|
Isal 2:12 For the day of the LORD of hosts [shall be] upon every [of
83 f 0 e IO p dav o p DRD | IS 5148 0

Isai 13:9 Behold, the day of the TLORD cometh, cruel both with wrat

it View Search ‘ﬂurds Options  Wind

il BRSO : s¥iew |sai 13;6 fing)
"Howl ve;, tor v of the LORD [is] at hand; it
destruction from the Almighty. (KJS)

30 DS O B BN B o} kil ) i R DRV IR
“Wail, Tor the day of the Lord is near! It will come as destruction from
the Almighty. (NASB)
"Therefore shall all hands be faint, and every man's heart shall melt:

shall come as a

Remember ro minimize STUDY windows you don’t want synchronized.

Using SEARCH Files

SEARCH generates files whose filenames have a “.SMS” extension. So,
when you save a SEARCH file as “KING”, it is stored as “KING.SMS”,
Companion automatically appends the “.SMS” extension for you.

Saving SEARCH Files

You can name and store searches to disk:

Save As

To save a SEARCH, pick Save As... from the File menu. Then, enter a
file name. If the file exists, you are warned before replacing it.

Save

To save an existing SEARCH file, select Save from the File menu. If the
file does not have a name, Companion asks for one (like Save As).
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Opening SEARCH Files

To Open a SEARCH file, you must be in SEARCH. (I need be, do a
trivial search). Select Open from the File menu and choose the file.

Merging SEARCHes

You can Merge a saved SEARCH file with the current SEARCH using
AND, OR, XOR, or NOT logic to build compound SEARCHes. With a
SEARCH window active, select Merge... from the File menu. The Merge
dialog box gives you merge choices:

Alter you exit the Merge dialog box, the File Opcn dialog box dppCdlS
Select the SEARCH file you wish to ¥ ¥
merge. Companion then merges that
file with the active SEARCH on the
screen according to logic you
selected.

OR This creates a SEARCH containing all verses in either of the
SEARCHes. Use it to combine two SEARCH lists into one
comprehensive list.

AND  This builds a SEARCH containing only those verses in both of
the original SEARCHes. Use it when you want to look al verses common
{0 two SEARCHes.

XOR  This stands for “eXclusive OR.” I{ creates a SEARCH contain-
ing verses in either original search—bur nor both.

NOT  This removes from the current screen SEARCH any verses in
the saved search lile. Assume your current screen SEARCH is for the
word “king”™ and your saved SEARCH file is for the word “Israel.” If you
select the NOT operator and open the saved SEARCH file, the result is
all verses that contain the word “king” but not the word “Isracl.” Thus,
all verses containing “king of Israel” would be eliminated. Note that
NOT logic is order-dependent. If the current screen search and saved
search file were reversed, you would get a different result.

Examples:
The screen SEARCH contains verses: 1,2,3,5
The saved SEARCH contains: _ 1,2, 4
OR result; 1,2,3.4,5
AND result: [, 2
XOR result: 3,4,5
NOT result; 3,5
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Using Ranked Search

Ranked Search provides a list of Bible books ordered by the
number of verse “hits” for each book, from most frequent to least
frequent. Click the Ranked Search button on the Ribbon bar or
choose Ranked Search... from the Search men,

To advance the Search results to a book displayed in the list, double-
click it. You can also obtain more detailed search information by clicking
the Stats... button to bring up Search Statistics.

Using Search Statistics

Scarch Statistics gives you a panoramic view of a SEARCH, with the
number of hits by book and hits per chapter in a book. Choose Search
Statistics... on the Search menu.

!

Search Statistics provides the total number of hits in each book and the
approximate percentage of the total number of hits. For instance, Psalms
has 40 hits, and about 2% of the total number of hits, 1,917,

Note: Companion uses integer math to compute Search Stalistics percen-
tages. This is fast, but it sacrifices some accuracy due to rounding errors.
Since the purpose s to give the user an overview, we felt areater
accuracy was not justified.
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You can cursor around on the books using the arrow and tab keys. It we
cursor to Psalms and press <linter>, we can view Search Statistics on a
chapter-by-chapter basis for Psalms:

In Psalins, chapter 45 has the most hits. Press <Ese> to return to books.
Press <linter> to advance SEARCH to chapter 45,

The SEARCH Mode



