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Chapter 5. Bible Resources: COMMENTARY,
TOPICS, and LEXICON

Bible Resources are (0ols to supplement your Bible study. They include
COMMENTARY, which is verse-dependent, and LEXICON and
TOPICS, which are verse-independent.

"This Chapter explains the general features of Bible Resources then
discusses specific Resources.

General Features of Bible Resources

Setting Optional Write Access

Resource Write Access, selected from the Options menu, controls
updating of Resources:

If write access is enabled, the
Resource “auto-saves” text when

+
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Faston's City you exit the Resource or jump to
Mt Henry Cinty Ly
77 |Mave's Cmty another text within a Resource.
. [People’s NT C . : .
i szgﬁj;,ﬁe;""' Use write access with care, since
Fe [ min's Lty — you may enter or delete text and
| Tapres Cmty i
Lieasury SK permanently save it. By default,

Vine's Cmiy

“Write Access” is enabled for
COMMENTARY and UXREF,
and disabled for all others.

Note: Not all Resources may appear in the list if the publisher of the
work did not wish to permit users to edit the work for their own use.

Editing Resources

The Resource Edit button toggles you in and out of the Hypertext =
. . . '“‘
and Edit/Display modes, Elrﬂ

To save changes to a Resource, yvou must enable Resource Write
Access through the Options menu. You cannot save changes to CD-
based databases.,

If Resources Write access is enabled for the resource in the aclive
window, the pencil icon displays on the Resource Fdit button A
when you foggle (o the Edit/Display mode.
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Using and Creating Hypertext Jumps

Companion Bible Resources support “hypertext” jumps. These are “fast
[orwards™ to other texts within the same or other Resources. The types
of jumps can be classified as follows:

From To

COMMENTARY(s) TOPICS and Verse References
LEXICON LEXICON and Verse References
TOPICS TOPICS and Verse References

Available jumps are underlined and green. You double-click them to
Jump to the referenced text.

Verse jumps are checked for validity. For example, a jump to Genesis
51:1 1s not allowed.

Note: To create a simple and [exible hypertext system—usable and
extensible by our users, Companion uses an “aggressive” hypertext
systeny. Occasionally, non-senstcal jumps can appear. For example, in
LEXICON, you can sometimes “jump’ to the number of KIV
occurrences. That Strong’s number is obviously not related to your
definition.

Jump History

As you make jump after jump through a Resource, your last
seven jumps within a Resource are stored so you can return to

them by pressing <Ese>.

Adding Jumps in COMMENTARY and TOPICS

You can butld your own jumps. See the “COMMENTARY" and
“TOPICS” sections later in this Chapter for instructions. If you are
building your own cross-references, you can import verse references
based on SEARCH files (saved from in SEARCH mode) and paste them,
pre-formatted, into a Resource. (See “Cross-Reference Features™ below
for more information.)

Adding Jumps in LEXICON

You can create additional hypertext jumps (in Edit Mode with Resource
Write Access ON) to other LEXICON definttions. You do this by
entering a valid Strong’s number—or the record number displayed in the
window title for non-Strong’s LEXICONs like the UBS Greek NT
Dictionary—preceded by one of several “keywords,” then a single space.
(Remember to prefix Hebrew/O'T Strong’s numbers with a zero.) The
“keywords™ help Companion identify potential jumps.
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Valid Strong’s keywords include:

and from origin
as From to
cf of +

Example: “This Hebrew word is related to 0430 and 0431.” In this case,
both 0430 and 0431 would be valid “jumps.” After you switch back to
Display/Hypertext Mode, the “jump” will be highlighted in green if you
have entered it correctly.

Searching Resources

You can search all records within a Resource for words and/or

numbers. This 1s a simple, sequential text search for the words. P
Multple words and/or numbers are treated as a logical AND.

‘There is no word order support or case sensitivity.

Select Word/Phrase... from the Search menu or click the Word/Phirase
button within a Resource
window, enter your word(s)
and/or number(s), and begin the
search.

s find: Idngul

SRl anael
E - {angels
# = {anger

3 fangered

The Resource window titles
show the current hit and total
b hits. You can “page” lhmugh the
e hits by pressing the <Ctrl> key
S oo i with <PgUp>, <Pgbhn>,

S <Home> or <End>. The search
words are not highlighted. You can use this feature to search topically for
related LEXTCON entries, TOPIC entries, and COMMENTARY verses.
For example, you could search BDB/Thayers for the word “father” and
page through that lexicon’s definitions that refer to the word “father.

angle
sy
. Janguizh
Aniam

L

Cross-Reference Features

‘There are two features that support your use of cross-references: cross-
reference importing and crogs-reference exporting.
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Cross-Reference Importing

You can convert and import SEARCH filcs into text-based Resources.
Choose Convert Search to Paste XRefs from the Bdil menu.

L5

File  Edit Window
(o)} B 5 e | T | Ced o) ) <2 B
T = . ,B

IPenpie's NI Cmty L_*J

People's NT Cmty - Matt 1:18 - Hit 1 of 103

#ME1:18

*The birth of Jesus Christ.* The word rendered here "birth"

is the same in Greek that is translated "genealogy” in

#1:1

*Mary was espoused.” Not married, but engaged. Betrothal
was, from the times of the patriarchs, a formal ceremony, and
was regarded a binding obligation. It generally lasted a whole
year before marriage. After betrothal nnfaithfulness was
regarded adultery.

*Betore they came together.* Before marriage.

*She was found.* The angel predicted her conception, and
when the prediction was verified she probably did not hesitate
reveal it. Her heart would be tilled with joyous pride

Note: You can do this from SEARCH mode or in a Resource editor. If
you are in a Resource, you are asked to select a SEARCH file. If you are
in a SEARCH window, the current SEARCI results are used.

The verse references are converted to hypertext jump format and put in
the Windows Clipboard. Put the cursor in the Resource text where you
want the cross-references and select Paste from the Edil menu.

Cross-Reference Exporting

You can take cross-references from a Resource and convert them into a
SEARCH file. You can then retrieve and manipulate that SEARCH,
including merging it with other SEARCHes. Within a Resource, choose
Convert Xrefs to Search File from the Edit menu. You are then prompted
for a SEARCH file name, and the cross-references are converted to a
binary format compatible with SEARCH.

Strong’s Numbers

In the KJS with embedded Strong’s, there is a *“(0)” place holder. This
shows an implied Strong’s number created by translation into English.
For instance, English usage may break up a single Strong’s number into
two or more words, separated by other words. This lets you determine
how many times the Strong’s number actually appears in the original.
You cannot search or get a definition for this number (zero).
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COMMENTARY

COMMENTARY is a “verse-hy-verse” Resource synchronized
to an active Bible STUDY window. To open COMMENTARY,
click the New COMMENTARY button or pick New Commen-

tary on the File menu. You can open up to 10 COMMENTARY

windows,

There are several types of COMMENTARY content, including:
* User-created Commentary

* Your own verse by verse notes

 Uiser-created Xrefs

* Your own verse cross-references

* T'reasury Scripture Knowledge

* Optional cross-references

* Matthew Henry

* Devotional Bible Commentary.

You can change the COMMENTARY content by the Ribbon Bar list box
or by selecting Switch Window Content... on the View menu.

Switching COMMENTARYSs

By pressing <Ctrl><V>, you can toggle through available :
COMMENTARYSs in a COMMENTARY window. Or, you can click the
UP and DOWN arrows next to the Ribbon Bar list box:

=] Window Content Previous button
(=] Window Content Next button

Companion also offers a number of “quasi-commentaries,” which refer
you to TOPICS Resources that refer to that verse. You can press
<Ctrl><Q> 1o toggle through just these types of COMMENTARYSs.

You can create your own User Commentary and User Xrefls. You can
also edit most other Resources, if they are not on CD and if you have
Resource Write Access enabled for them. You need not explicitly save
changes to COMMENTARY. Since it synchronizes to verse changes in
other windows, it automatically saves changes when it moves to another
verse.

Note: Turn write access ON and OFF for Resources to enable or prevent
updating them. Select Resource Write Access on the File menu.
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Editing COMMENTARY

Resource Edit on the Edit menu “toggles™ between Display/Edit Mode
and the Hypertext Mode. If you are in Display/Hypertext Mode, any
hypertext “jumps” are highlighted in green (like Window’s Help). You
double-click them to “jump” to the associated text, Advanced users can
create and extend Resources with hypertext jumps and Xrefs

Hypertext Mode

COMMENTARY windows use a Hypertext Mode (0 display text —
in a selected Resource font and allow hypertext jumps to TOPICS HH

and cross-references. In this mode, text cannot be edited. You
can, however, select text to be copied (o the Clipboard by “dragging™ the
mouse. Available hypertext jumps appear in green text. Double-click one
to “jump.” I you jump on a cross-reference, 2 special window displays
the verse(s). You can print or copy to the Clipboard from that window. I
you leave the window open. it is used for luture “jumps.”

Display/Edit Mode

{n Disply/Edit Mode, you can change or add text to the ,
COMMENTARY Resource. Edit Mode uses a paragraph- ,55,
oriented editor similar to NOTEPAD, using a Windows default '
font. Word wrap is based on the window margins, not your printer
margins. It is intended to keep long text lines {rom going ofl the end of
the window where they cannot be seen. When you print {rom
COMMENTARY, your printer margins are enforced at that time. Para-
graphs will reformat to printer margins.

File Edit View Search Words

Options  Window Help

Lo 3 ] | [ (SRR (o] [ (2] I ] (2] wucm
[Penhle's NT Cmity |_£| Elﬁﬂ.m . JE ‘ cdom.: .
#Joh1:1-3 L
SUMMARY OF JOHN 1

*The Beginning of Christ's Ministry®

The Word Made Flesh

The Witness of John

John's Disciples Pointed to Christ

The Lord Calls His First Disciples

An Israelite Indeed

*Iu the beginning was the Word®, etc. The tirst fourteen

verses are mfroductory. In order to set at rest all confroversy

the Divine nature of Jesus, John glances, in the first three

verses, back to the beginning, recorded in Genesis, and attinms:
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You may type comments for the current verse. Space for 30,000
characlers 1s provided for each verse. The current STUDY verse is
indicated at the top of the VIEW window and at the top of the COM-
MENTARY window.

[n Edit Mode, you need not worry about “saving” changes. Assuming
you have enabled Write Access on the Options menu for the Resource,
Companion saves changes automatically when you:

* Enter new comments for a verse
« Ldit existing comments
» Exit COMMENTARY

« Exit Companion.

Moving through COMMENTARY

You can move through your comments using the following cursor
control keys:

Movement Key(s)

Go to top of window, <PgUp>

Go to beginning ol a line. <Home>
Move up one line. <Up>

Left one word. <Ctrl><left>
Left one character. <L.eft>

Right one character. <Right>
Right one word. <Ctrl><Right>
Move down one line. <Down>

Go to end of line. <KEnd>

Go to bottom of window. <PgDn>
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Creating COMMENTARY Hypertext “Jumps”

Cross-Reference Hypertext “Jumps”

Any cross-references must be preceded by a “#” sign on the line. If a
verse number is not preceded by a book or chapter notation, we assume
the “current’ book and chapter. Bible book abbreviations (ol 4 characters
or less) should follow the Companion or “*Alternate” book nanting
standards listed in the Glossary, although we try to interpret other names
based on the Companion naming convention. It you “Paste” converted
SEARCH files, the Book naming is done for you.

==

File Edit Yiew Search Words Qptions Window Help

E: s g e W@D
[<iefs-Personal  [3] E} folliE (2=

=i s et .- Yiew Gene 1:1 [KJS] -
Sme i the beonmmo (md created the he'tven and the ear th
carth ¥ xnefs-Persona enei:l

the de ——
S And ¢ Ezzrt'f:leih;l!uwmg hyperir:xi verses:

light, {4 22
And g 5” )
evenity|
" And {{}
let it d|}
and di S e
waters which [were] 'ﬂmve the Immment and 1t was 50. ° And (m(T

Hypertext “dJumps” to TOPICS

You can create “jumps” to TOPICS Resources. Companion interprets a
number on the end of a line (one you press <Enter> after) as a potential
TOPIC jumip. So, you can add a line at the bottom of a COMMENTARY
Resource such as: “See Topic 3243”. Each topic jump inust be on a
separate line (so the number is at the end of the line).

Finding a Term in COMMENTARY

o find a term within the text of an individual COMMENTARY entry (in
Ldit Mode only), select Find from the Search menu.

COMMENTARY Searches

Conipanion offers searching throughout the active
COMMENTARY Resource for words and/or numbers. Click (he
Word/Phrase button or select Word/Phrase from the Search
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ment. Word Order and Case Sensitivity are ignored.

The window title shows the current “hit” number and the total number of
“hits.” The following is the result of a search for “angel” in the PNT:

=

File FEdit View Search Yords Oplions Window

| R 8

1Peuplc s NI Cinty

ﬁ MU1:L8
e bicth of Jesus Christ.® The word rendered here "birth
is the samne in Greek that is translated "genealogy” in
#1:1
*Nary was espoused.* Not married, but engaged. Betrothal
wits, from the times of the patriarchs, a formal ceremony, and
wis regarded a binding obligation. Tt generally lasted a whole
vear betfore marriage, After betrothal untaithfulness was
regarded adultery.
s #Before they came together.* Before marriage.
*She was found.® The angel predicted her conception, and
when the prediction was verified she probably did not hesitate
to reveal it. Her heart would be filled with joyous pride

Once the search is complete, you can “page” through the “hits” using the
following key combinations:

<Ctrl><Home> Show first “hit”
<Ctrl><PgUp> Show previous “hit”
<Ctrl><PgDn> Show next “hit”
<Ctrl><End> Show last “hit”

Note: You must be in Display/Hypertext Mode to page through “hits.”

Copying COMMENTARY Text to the Clipboard

To copy text to the Windows Clipboard, select text to copy and click the
Copy button on the Ribbon Bar or choose Copy from the Edit menu.

Pasting Text into COMMENTARY

To paste text from the Windows Clipboard in Edit Mode, position the
cursor where you want the text, and select Paste from the Edit menu.

Printing from COMMENTARY
To print from COMMENTARY, click the Print button or select
Print on the File menu.

Note: You can include COMMENTARY when you print Bible text.
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Exiting COMMENTARY

To exit COMMENTARY, select Close from File menu. The window js
removed and any changes to the comments are saved (if applicable).

TOPICS

TOPICS are independent Resource windows for topical studies—such as
topical works and dictionaries. A LEXICON is 4 specialized type of
TOPIC Resource. You can have up to 10 TOPICS windows open. The
TOPIC number is in the window's title bar.

To open TOPIC, pick the New Topic button or choose New Topic
on the View menu. It a TOPIC window is the active window, m
Companion prompts for a new topic for that window. 1f another '
window type is active, a new topic window is created. Topic “0”
generally has an index to the TOPICS in a Resource. You can hypertext
to the alphabetical Resource entries.

-
—Eile Edit View Search Words Options  Window

BEEN e )]
INave's Topical !}JE“E A

Jd L
(G0 [ 1O A | iy (2 —

jr— LV

—_—
—

Moving Sequentially through TOPICS

You cuan move to the previous and next TOPIC by holding down the
<Shift> key and clicking the Left and Right mouse buttons, respectively.
This lets you move forward and backward one TOPIC at a time. You can
also press the <+> and <-> keys.
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Changing TOPIC Contents

You can change the type of TOPIC by selecting Switch Window
Content... on the View menu or click the list box on the Ribbon Bar.

Switch TOPICS Hotkey

By pressing <Ctrl><V> you can toggle through available TOPICS
databases in a TOPIC window. You can also click the UP and DOWN
buttons next to the list box an the Ribbon Bar.

Creating New TOPICS

You can create your own topics within TOPICS. Each TOPICS database
accommodates up to 32,767 topics. Assuming you have Write Access
(on Options menu) enabled on a non-CD-based TOPIC file, simply sclect
an unused TOPICS number and start entering text. We suggest you
creile a “menu” of hypertext jumps for your TOPICS so you can use it to
Iind your entries from a single point.

=

File Edit View Search Words Options Window
MR )
[Tupics-Persuna! L_i_,_] = EI@I[@I 5

= Topics-Persona
My Own Personal Topic Menu

Help

My First Sermon 20001
My Longest Sermon 20002
My Last Sermon 20603

Menu ot My Ilustrations 21000

i My resume 22001

It you farget which topic number(s) you created, you can also use the
Word/Phrase search for keywords.

Creating Hypertext Jumps

You can add hypertext jumps to other TOPICS. Enter a valid TOPIC
number (through 32,767) at the end of a line—you must press <Enter>

alter the number. (See screen above.) Thus, you can only have ane
TOPIC jump per line.
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